36 lines
No EOL
1,023 B
Nix
36 lines
No EOL
1,023 B
Nix
{
|
|
description = "Portfolio rust configuration";
|
|
|
|
inputs = {
|
|
nixpkgs.url = "github:nixos/nixpkgs/nixpkgs-unstable";
|
|
flake-utils.url = "github:numtide/flake-utils";
|
|
rust-overlay = {
|
|
url = "github:oxalica/rust-overlay";
|
|
inputs.nixpkgs.follows = "nixpkgs";
|
|
inputs.flake-utils.follows = "flake-utils";
|
|
};
|
|
};
|
|
|
|
outputs = { self, nixpkgs, flake-utils, rust-overlay }:
|
|
flake-utils.lib.eachSystem flake-utils.lib.allSystems (system:
|
|
let
|
|
overlays = [ (import rust-overlay) ];
|
|
pkgs = import nixpkgs {
|
|
inherit system overlays;
|
|
};
|
|
rust = pkgs.rust-bin.fromRustupToolchainFile ./rust-toolchain.toml;
|
|
nodejs = pkgs.nodejs_20;
|
|
in
|
|
{
|
|
devShells = {
|
|
default = pkgs.mkShell {
|
|
buildInputs = [
|
|
(rust.override { extensions = ["rust-src" "rust-analyzer"]; })
|
|
nodejs
|
|
pkgs.cargo-leptos
|
|
pkgs.dart-sass
|
|
];
|
|
};
|
|
};
|
|
});
|
|
} |