nixos/modules/system/server/docker/default.nix
Florian RICHER 4de2c3203f
Some checks failed
check / check (push) Failing after 0s
modules: Remove unused imports
2024-10-28 21:26:34 +01:00

21 lines
No EOL
424 B
Nix

{ config, lib, ... }:
with lib;
let
cfg = config.modules.system.server.docker;
in
{
options.modules.system.server.docker = {
enable = mkEnableOption ''
Enable docker with my custom configurations
'';
};
config = mkIf cfg.enable {
virtualisation.docker = {
enable = true;
};
virtualisation.oci-containers.backend = "docker";
users.users.florian.extraGroups = [ "docker" ];
};
}