nixos/modules/system/server/distrobox/default.nix
Florian RICHER 34cbb44cc1
All checks were successful
check / check (push) Successful in 33s
Add distrobox
2024-06-18 19:44:19 +02:00

17 lines
No EOL
381 B
Nix

{ config, pkgs, lib, ... }:
with lib;
let
cfg = config.modules.system.server.distrobox;
in
{
options.modules.system.server.distrobox = {
enable = mkEnableOption ''
Enable distrobox with my custom configurations
'';
};
config = mkIf cfg.enable {
modules.system.server.docker.enable = true;
environment.systemPackages = with pkgs; [ distrobox ];
};
}