nixos/modules/system/hardware/plymouth/default.nix
Florian RICHER b7f82f87e8
All checks were successful
check / check (push) Successful in 34s
Big refactor (#1)
Reviewed-on: https://gitea.mrdev023.fr/florian.richer/nixos/pulls/1
Co-authored-by: Florian RICHER <florian.richer@protonmail.com>
Co-committed-by: Florian RICHER <florian.richer@protonmail.com>
2024-05-28 10:12:33 +02:00

16 lines
No EOL
302 B
Nix

{ config, lib, ... }:
with lib;
let
cfg = config.modules.system.hardware.plymouth;
in
{
options.modules.system.hardware.plymouth = {
enable = mkEnableOption ''
Enable plymouth with my custom configurations
'';
};
config = mkIf cfg.enable {
boot.plymouth.enable = true;
};
}