nixos/modules/system/hardware/keymaps/default.nix
Florian RICHER b7f82f87e8
All checks were successful
check / check (push) Successful in 34s
Big refactor (#1)
Reviewed-on: https://gitea.mrdev023.fr/florian.richer/nixos/pulls/1
Co-authored-by: Florian RICHER <florian.richer@protonmail.com>
Co-committed-by: Florian RICHER <florian.richer@protonmail.com>
2024-05-28 10:12:33 +02:00

23 lines
440 B
Nix

{ config, lib, ... }:
with lib;
let
cfg = config.modules.system.hardware.keymaps;
in
{
options.modules.system.hardware.keymaps = {
layout = mkOption {
default = "fr";
example = "fr";
description = ''
Set key layout (fr, us)
'';
type = types.str;
};
};
config = mkMerge [
(mkIf (cfg.layout == "fr") (import ./fr.nix {}))
(mkIf (cfg.layout == "us") (import ./us.nix {}))
];
}