100 lines
2.8 KiB
Nix
100 lines
2.8 KiB
Nix
{ pkgs, ... }:
|
||
|
||
{
|
||
imports = [
|
||
../common.nix
|
||
];
|
||
|
||
# Set your time zone.
|
||
time.timeZone = "Europe/Paris";
|
||
|
||
# Select internationalisation properties.
|
||
i18n.defaultLocale = "fr_FR.UTF-8";
|
||
|
||
i18n.extraLocaleSettings = {
|
||
LC_ADDRESS = "fr_FR.UTF-8";
|
||
LC_IDENTIFICATION = "fr_FR.UTF-8";
|
||
LC_MEASUREMENT = "fr_FR.UTF-8";
|
||
LC_MONETARY = "fr_FR.UTF-8";
|
||
LC_NAME = "fr_FR.UTF-8";
|
||
LC_NUMERIC = "fr_FR.UTF-8";
|
||
LC_PAPER = "fr_FR.UTF-8";
|
||
LC_TELEPHONE = "fr_FR.UTF-8";
|
||
LC_TIME = "fr_FR.UTF-8";
|
||
};
|
||
|
||
nixpkgs.config.allowUnfree = true;
|
||
|
||
services.udev.packages = [ pkgs.yubikey-personalization ];
|
||
services.pcscd.enable = true;
|
||
|
||
programs.gnupg.agent = {
|
||
enable = true;
|
||
enableSSHSupport = true;
|
||
};
|
||
|
||
# List packages installed in system profile. To search, run:
|
||
# $ nix search wget
|
||
environment.systemPackages = with pkgs; [
|
||
vim
|
||
nixd
|
||
|
||
# For debugging and troubleshooting Secure Boot.
|
||
sbctl
|
||
|
||
# Usefull tools to debug
|
||
gdb
|
||
lldb
|
||
gammaray # QT Inspector
|
||
|
||
yubikey-manager
|
||
|
||
# Usefull for automatic informations collect software like KDE
|
||
vulkan-tools # For vulkaninfo command
|
||
wayland-utils # For wayland-info command
|
||
glxinfo
|
||
clinfo
|
||
aha
|
||
usbutils
|
||
pciutils
|
||
];
|
||
|
||
services.fwupd.enable = true;
|
||
|
||
# Define a user account. Don't forget to set a password with ‘passwd’.
|
||
users.users.florian = {
|
||
isNormalUser = true;
|
||
description = "florian";
|
||
extraGroups = [ "networkmanager" "wheel" ];
|
||
};
|
||
|
||
# Downloads and provides debug symbols and source code for nix derivations to gdb and other debuginfod-capable debuggers as needed.
|
||
# Require https://github.com/symphorien/nixseparatedebuginfod?tab=readme-ov-file#gdb
|
||
services.nixseparatedebuginfod.enable = true;
|
||
|
||
# networking.wireless.enable = true; # Enables wireless support via wpa_supplicant.
|
||
|
||
# Configure network proxy if necessary
|
||
# networking.proxy.default = "http://user:password@proxy:port/";
|
||
# networking.proxy.noProxy = "127.0.0.1,localhost,internal.domain";
|
||
|
||
# Enable networking
|
||
networking = {
|
||
networkmanager.enable = true;
|
||
firewall.enable = true;
|
||
};
|
||
|
||
# Open ports in the firewall.
|
||
# networking.firewall.allowedTCPPorts = [ ... ];
|
||
# networking.firewall.allowedUDPPorts = [ ... ];
|
||
# Or disable the firewall altogether.
|
||
# networking.firewall.enable = false;
|
||
|
||
# This value determines the NixOS release from which the default
|
||
# settings for stateful data, like file locations and database versions
|
||
# on your system were taken. It‘s perfectly fine and recommended to leave
|
||
# this value at the release version of the first install of this system.
|
||
# Before changing this value read the documentation for this option
|
||
# (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
|
||
system.stateVersion = "25.05"; # Did you read the comment?
|
||
}
|