Florian RICHER
a4a651133b
All checks were successful
check / check (push) Successful in 36s
- Support of gamescope for HDR - Best integration with udev devices - Add proton-ge
22 lines
460 B
Nix
22 lines
460 B
Nix
{ config, pkgs, lib, ... }:
|
|
|
|
with lib;
|
|
let
|
|
cfg = config.modules.system.apps.steam;
|
|
in
|
|
{
|
|
options.modules.system.apps.steam = {
|
|
enable = mkEnableOption ''
|
|
Enable steam with my custom configurations
|
|
'';
|
|
};
|
|
config = mkIf cfg.enable {
|
|
programs.steam = {
|
|
enable = true;
|
|
extraPackages = with pkgs; [ gamescope ];
|
|
extraCompatPackages = with pkgs; [ proton-ge-bin ];
|
|
};
|
|
|
|
hardware.steam-hardware.enable = true;
|
|
};
|
|
}
|