nixos/modules/system/apps/steam/default.nix
Florian RICHER a4a651133b
All checks were successful
check / check (push) Successful in 36s
steam: Move to system instead of Flatpak
- Support of gamescope for HDR
- Best integration with udev devices
- Add proton-ge
2024-09-05 22:47:19 +02:00

22 lines
460 B
Nix

{ config, pkgs, lib, ... }:
with lib;
let
cfg = config.modules.system.apps.steam;
in
{
options.modules.system.apps.steam = {
enable = mkEnableOption ''
Enable steam with my custom configurations
'';
};
config = mkIf cfg.enable {
programs.steam = {
enable = true;
extraPackages = with pkgs; [ gamescope ];
extraCompatPackages = with pkgs; [ proton-ge-bin ];
};
hardware.steam-hardware.enable = true;
};
}