nixos/modules/home/shell/zsh/default.nix
Florian RICHER b7f82f87e8
All checks were successful
check / check (push) Successful in 34s
Big refactor (#1)
Reviewed-on: https://gitea.mrdev023.fr/florian.richer/nixos/pulls/1
Co-authored-by: Florian RICHER <florian.richer@protonmail.com>
Co-committed-by: Florian RICHER <florian.richer@protonmail.com>
2024-05-28 10:12:33 +02:00

37 lines
No EOL
790 B
Nix

{ config, pkgs, lib, ... }:
with lib;
let
cfg = config.modules.home.shell.zsh;
in
{
options.modules.home.shell.zsh = {
enable = mkEnableOption ''
Enable zsh with my custom configurations
'';
};
config = mkIf cfg.enable {
programs.zsh = {
enable = true;
autosuggestion.enable = true;
syntaxHighlighting.enable = true;
initExtra = ''
[[ ! -f ${./p10k.zsh} ]] || source ${./p10k.zsh}
'';
plugins = with pkgs; [
{
file = "powerlevel10k.zsh-theme";
name = "powerlevel10k";
src = "${zsh-powerlevel10k}/share/zsh-powerlevel10k";
}
{
file = "p10k.zsh";
name = "powerlevel10k-config";
src = zsh-powerlevel10k;
}
];
};
};
}