nixos/modules/home/shell/direnv/default.nix
Florian RICHER 4de2c3203f
Some checks failed
check / check (push) Failing after 0s
modules: Remove unused imports
2024-10-28 21:26:34 +01:00

18 lines
No EOL
305 B
Nix

{ config, lib, ... }:
with lib;
let
cfg = config.modules.home.shell.direnv;
in
{
options.modules.home.shell.direnv = {
enable = mkEnableOption ''
Enable direnv with my custom configurations
'';
};
config = mkIf cfg.enable {
programs.direnv = {
enable = true;
};
};
}