nixos/modules/home/shell/atuin/default.nix
Florian RICHER 4de2c3203f
Some checks failed
check / check (push) Failing after 0s
modules: Remove unused imports
2024-10-28 21:26:34 +01:00

22 lines
No EOL
433 B
Nix

{ config, lib, ... }:
with lib;
let
cfg = config.modules.home.shell.atuin;
in
{
options.modules.home.shell.atuin = {
enable = mkEnableOption ''
Enable atuin with my custom configurations
'';
};
config = mkIf cfg.enable {
programs.atuin = {
enable = true;
settings = {
# Uncomment this to use your instance
# sync_address = "https://majiy00-shell.fly.dev";
};
};
};
}