19 lines
No EOL
343 B
Nix
19 lines
No EOL
343 B
Nix
{ config, lib, ... }:
|
|
|
|
with lib;
|
|
let
|
|
cfg = config.modules.home.editors.emacs;
|
|
in
|
|
{
|
|
options.modules.home.editors.emacs = {
|
|
enable = mkEnableOption ''
|
|
Enable emacs with my custom configurations
|
|
'';
|
|
};
|
|
config = mkIf cfg.enable {
|
|
programs.doom-emacs = {
|
|
enable = true;
|
|
doomPrivateDir = ./doom.d;
|
|
};
|
|
};
|
|
} |