nixos/modules/home/editors/emacs/default.nix
Florian RICHER 4de2c3203f
Some checks failed
check / check (push) Failing after 0s
modules: Remove unused imports
2024-10-28 21:26:34 +01:00

19 lines
No EOL
343 B
Nix

{ config, lib, ... }:
with lib;
let
cfg = config.modules.home.editors.emacs;
in
{
options.modules.home.editors.emacs = {
enable = mkEnableOption ''
Enable emacs with my custom configurations
'';
};
config = mkIf cfg.enable {
programs.doom-emacs = {
enable = true;
doomPrivateDir = ./doom.d;
};
};
}