nixos/modules/home/apps/firefox/default.nix
Florian RICHER bf45f5ebe3
All checks were successful
check / check (push) Successful in 35s
Update home-manager + add Firefox
2024-06-25 20:07:09 +02:00

44 lines
896 B
Nix

{ config, pkgs, lib, ... }:
with lib;
let
cfg = config.modules.home.apps.firefox;
in
{
options.modules.home.apps.firefox = {
enable = mkEnableOption ''
Enable firefox with my custom configurations
'';
};
config = mkIf cfg.enable {
programs.firefox = {
enable = true;
nativeMessagingHosts = [
pkgs.kdePackages.plasma-browser-integration
];
profiles = {
perso = {
id = 0;
name = "Perso";
extensions = with pkgs.nur.repos.rycee.firefox-addons; [
ublock-origin
bitwarden
floccus
plasma-integration
istilldontcareaboutcookies
darkreader
];
settings = {
# Enable multi-pip
"media.videocontrols.picture-in-picture.allow-multiple" = true;
};
};
};
};
};
}