Florian RICHER
b7f82f87e8
All checks were successful
check / check (push) Successful in 34s
Reviewed-on: https://gitea.mrdev023.fr/florian.richer/nixos/pulls/1 Co-authored-by: Florian RICHER <florian.richer@protonmail.com> Co-committed-by: Florian RICHER <florian.richer@protonmail.com>
32 lines
No EOL
948 B
Nix
32 lines
No EOL
948 B
Nix
{ config, pkgs, lib, ... }:
|
|
|
|
with lib;
|
|
let
|
|
cfg = config.modules.home.apps.chromium;
|
|
in
|
|
{
|
|
options.modules.home.apps.chromium = {
|
|
enable = mkEnableOption ''
|
|
Enable chromium with my custom configurations
|
|
'';
|
|
};
|
|
config = mkIf cfg.enable {
|
|
programs.chromium = {
|
|
enable = true;
|
|
|
|
package = pkgs.chromium.override {
|
|
enableWideVine = true; # Enable DRM
|
|
};
|
|
|
|
extensions = [
|
|
{ id = "cjpalhdlnbpafiamejdnhcphjbkeiagm"; } # Ublock Origin
|
|
{ id = "nngceckbapebfimnlniiiahkandclblb"; } # Bitwarden
|
|
{ id = "fnaicdffflnofjppbagibeoednhnbjhg"; } # Floccus Bookmark manager
|
|
{ id = "fihnjjcciajhdojfnbdddfaoknhalnja"; } # I don't care about cookies
|
|
{ id = "cimiefiiaegbelhefglklhhakcgmhkai"; } # Plasma Integration
|
|
{ id = "eimadpbcbfnmbkopoojfekhnkhdbieeh"; } # Dark reader
|
|
{ id = "mnjggcdmjocbbbhaepdhchncahnbgone"; } # SponsorBlock
|
|
];
|
|
};
|
|
};
|
|
} |