nixos/hosts/perso-laptop/configuration.nix
Florian RICHER 885148a1f3
All checks were successful
check / check (push) Successful in 2m17s
perso-laptop: Add steam
2024-12-22 23:26:35 +01:00

56 lines
1.2 KiB
Nix
Raw Permalink Blame History

This file contains ambiguous Unicode characters

This file contains Unicode characters that might be confused with other characters. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

# Edit this configuration file to define what should be installed on
# your system. Help is available in the configuration.nix(5) man page
# and in the NixOS manual (accessible by running nixos-help).
{ ... }:
{
imports =
[
../../modules/system
# Include the results of the hardware scan.
./hardware-configuration.nix
];
# Bootloader.
boot.loader.systemd-boot.enable = true;
boot.loader.efi.canTouchEfiVariables = true;
networking.hostName = "nixos-laptop-perso"; # Define your hostname.
hardware.nvidia.prime = {
offload = {
enable = true;
enableOffloadCmd = true;
};
# Make sure to use the correct Bus ID values for your system!
# information bus: pci@0000:00:02.0
intelBusId = "PCI:0:2:0";
# information bus: pci@0000:01:00.0
nvidiaBusId = "PCI:1:0:0";
};
modules.system = {
apps = {
steam.enable = true;
flatpak.enable = true;
};
desktop = {
plasma.enable = true;
};
hardware = {
bluetooth.enable = true;
gamingKernel.enable = true;
keymaps.layout = "fr";
nvidia.enable = true;
pipewire.enable = true;
plymouth.enable = true;
printing.enable = true;
waydroid.enable = true;
};
};
}