nixos/hosts/perso-desktop/configuration.nix
Florian RICHER cce1f72410
All checks were successful
check / check (push) Successful in 33s
perso-desktop: Enable secure boot
2025-01-03 23:51:19 +01:00

60 lines
1.3 KiB
Nix
Raw Permalink Blame History

This file contains ambiguous Unicode characters

This file contains Unicode characters that might be confused with other characters. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

# Edit this configuration file to define what should be installed on
# your system. Help is available in the configuration.nix(5) man page
# and in the NixOS manual (accessible by running nixos-help).
{ lib, ... }:
{
imports =
[
../../modules/system
# Include the results of the hardware scan.
./hardware-configuration.nix
];
# Bootloader.
# For lanzaboote see https://github.com/nix-community/lanzaboote/blob/master/docs/QUICK_START.md
boot.loader.systemd-boot.enable = lib.mkForce false;
boot.lanzaboote = {
enable = true;
pkiBundle = "/var/lib/sbctl";
};
boot.loader.systemd-boot.windows = {
"11-pro" = {
title = "Windows 11 Pro";
efiDeviceHandle = "HD1b";
};
};
boot.loader.efi.canTouchEfiVariables = true;
networking.hostName = "nixos-desktop-perso"; # Define your hostname.
modules.system = {
apps = {
flatpak.enable = true;
steam.enable = true;
};
desktop = {
plasma = {
enable = true;
};
};
hardware = {
bluetooth.enable = true;
gamingKernel.enable = true;
keymaps.layout = "us";
nvidia.enable = true;
pipewire.enable = true;
plymouth.enable = true;
printing.enable = true;
waydroid.enable = true;
};
server = {
distrobox.enable = true;
};
};
}