25 lines
No EOL
576 B
Nix
25 lines
No EOL
576 B
Nix
{
|
|
description = "Standard packages";
|
|
|
|
inputs = {
|
|
nixpkgs.url = "github:nixos/nixpkgs/nixpkgs-unstable";
|
|
flake-utils.url = "github:numtide/flake-utils";
|
|
};
|
|
|
|
outputs = { self, nixpkgs, flake-utils }:
|
|
{
|
|
lib = import ./lib { inherit (nixpkgs) lib; };
|
|
} // flake-utils.lib.eachDefaultSystem (system:
|
|
let
|
|
pkgs = import nixpkgs { inherit system; };
|
|
in
|
|
{
|
|
packages = import ./pkgs {
|
|
inherit pkgs;
|
|
};
|
|
|
|
devShells = {
|
|
default = import ./shell.nix { inherit pkgs; };
|
|
};
|
|
});
|
|
} |