30 lines
627 B
Nix
30 lines
627 B
Nix
{
|
|
description = "Environnement de développement pour kubernetes pour apprendre";
|
|
|
|
inputs = {
|
|
nixpkgs.url = "nixpkgs";
|
|
flake-utils.url = "github:numtide/flake-utils";
|
|
};
|
|
|
|
outputs = {
|
|
nixpkgs,
|
|
flake-utils,
|
|
...
|
|
}: flake-utils.lib.eachSystem flake-utils.lib.allSystems (system:
|
|
let
|
|
pkgs = import nixpkgs { inherit system; };
|
|
in {
|
|
devShells = rec {
|
|
default = pkgs.mkShell {
|
|
packages = with pkgs; [
|
|
minikube
|
|
kubectl
|
|
docker-machine-kvm2 # Required for run on NixOS
|
|
sops
|
|
];
|
|
};
|
|
};
|
|
}
|
|
);
|
|
}
|
|
|